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Setting Things Up

1. Open Ansys Electronics Display

2. Create a new model file
a. Hover over file in the top banner, and select New
b. Right click on file name in Project Manager, select Insert, select Insert HFSS
design
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3. Check solution type

a. On top banner, click on HFSS
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Select Solution Type
For wave port method, select Modal
Check “Save as default” to ensure new models will be of the modal solution

type
Click Ok
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Building the Model

Ground plane:

1. Select the Draw tab on the top banner
2. Select the rectangular prism

! Ansys Electronics Desktop 2022 R1 - SingleTraceTuterial - HFS5Design2 - 30 Modeler - [SingleTraceTutorial - HF55Design2 - Modeler]
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3. Construct the shape anywhere on the work plane
4. The properties window should pop up. Adjust Position, XSize, YSize, and ZSize.
a. To access the properties window, double click

-4 Model
“CreateShape” (where Shape is refers to whatever | E-dP Solids
shape your object is—such as Box, Cylinder, etc). This Eg:‘;‘;i;
can be found by expanding the object’s tree. » -0

5. Create variables for all important properties
a. Type “$” followed by your variable name into any of the size or position boxes.

Click the enter key. Ansys will recognize any non-numerical value as a variable,
and prompt you to define it.
b. In the Add Variable window, set the variable’s value. Make sure to set the units
appropriately.
i.  $ ensures the variable is saved as a “Project Variable”, making it easy to
access later.

Command

Add Variable b4
| [Command CreateBox Name  [StpT

Coordinte Sys... Global

Posiion 000 Urit Type [Lengn ) =

XSize $SubW )
- Uit mm -

YSize $Subl. l =l

Type  [Project Variable =]
™ Show Hidden
0K Cancel Apply




ii. To access variables later: E_ )

e Right click on the file name in ¢ M ——
Project Manager, and select Project g - — :
Variables. B |

sults
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e The Project Variables window allows rerddoa A
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you to view and edit all project @ s Frject il
"1 Components Project Datasets...
variables.
Project Variables 1 Intrinsic Variables | Constants |
&+ Value " Optimization / Design of Experiments " Tuning " Sensitivity " Statistics
Name | Walug ‘ Unit ‘ Evaluated Valus Description | Read-only | Hidden | Sweep |
SSubW 5 mm B r r 2
| |ssubL 7 mm o 7mm r r 2
| |sSuipT 0.005 mm | 0.005mm r r 2
[# Show Hidden
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6. Assign materials
a. Double click on the object’s name in the model tree.
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b. The properties window will pop up. You can assign a name, appearance, and
material. For ease of visibility later on, you may want to raise the transparency.

Properties: SingleTraceTutorial - HF55Design2 - Modeler X
Adtribute
Mame WValue | Unit | Ewvalusted Value Description | Read-only ‘
Name Box1 ]
Material "vacuum” "vacuum" [
Saolve Inside v [
Orientation Global ]
Mode! v ]
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Display Wireframe l_ ]
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Color [E— ]
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OK Cancel




c. Expand the material drop-down. The material should be set to “vacuum” by
default.
Select “Edit...”

e. You can select a material from the library, or add your own material and
manually assign values to material properties. The ground plane’s material is

typically copper.

Select Definition x
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cast_iron SysLibrary Materials 1 80 1500000siemens/m 0 0
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__El
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f. Click Ok

Substrate:

1. Construct the shape the same way you did for the ground plane. Use variables in the
properties window to assign size and position.
2. Assign a material. This is often aluminum nitride, called “Al_N" in Ansys.

Microstrip:

1. Construct the shape. Use variables to assign size and position. The trace’s thickness
is typically the same as the ground plane.
2. Assign a material. This is typically copper.



Create an air boundary:

1.

Create a box of the same x and y-dimensions of the ground-plane, but significantly
bigger in the z-dimension (about 1-1.5 mm is usually good). This box should be

placed on the same work plane as the ground plane, and overlap the ground plane
and substrate exactly.

Assign the material of the box to be air.
Make sure Object is chosen in the Select menu found under the Draw tab on the top
banner. You may want to change this later to select specific faces or edges.

B File Edit View Project Draw Modeler HFS5 Tools
| I Cut %) Undo  Select Objec -~ & [@
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Save
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Select your air box by clicking on it in the work plane.
Right click on the box, select Assign Boundary, and select “Radiation...”

The Radiation Boundary pop-up will prompt you to name your boundary. Choose an
appropriate name and click OK.
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Cancel




7. Check that your boundary appears under Boundaries in the design tree in Project
Manager.

EI SingleTraceTutorial®
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Create ports:

1. Creating the wave ports involves drawing rectangles at either end of the microstrip.
2D shapes are drawn along the work plane grid, which is oriented on the XY-plane
by default. To draw a shape along a different plane, you will need to change the grid.
This can be done under the Draw tab.

a. You will most likely want the XZ grid.
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3D il 1 £ vateria
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2. Draw arectangle at one end of your microstrip, then assign appropriate position

and dimensions.
a. The wave port should be centered at the center of your microstrip. Its bottom

end should be aligned with the top edge of the ground plane.

b. Ideal Dimensions:
i. The height should be >4h, where h is the thickness of your substrate.

ii. The width should be ~5w, where w is the width of your microstrip.
iii. You can go bigger than this! If your simulation results look strange, it

may be worth increasing the size of your wave port.




3. Assign excitations
a. Select the created rectangle. Right click on the selection, click Assign
Excitation, then Port, then Wave Port.
b. Ansys allows you to set a number of modes and set an integration line for
each mode. The default setting are fine for many basic applications.
i. You can also change the characteristic impedance. The options are Zpi,
Zpv, Zvi, and Zwave. These will generally give different results. Zpv
and Zvi will only appear if an integration line is drawn such that a
unique voltage can be computed for that mode. Zwave is for
homogenous waveguides.
c. For this model, I used 1 mode with Zpi characteristic impedance.
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d. Click Next. Renormalize all modes to port impedance of 50 Ohm. Click Finish.
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e. You will be able to find the created rectangle = ] SingleTraceTutorial

. e - HFSSDesign2 (Modal Network)
under Sheets in the model tree. You will find the & 0 Companents
wave ports under Excitations in the design tree ::::iiEI o et
in Project Manager. - Boundaries
| - Radl
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f. Repeat this process for the second port. ;
Running Simulations
Simulation Setup:

1. Go to the Simulation tab on the top banner. Click Setup and select Advanced.
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2. Alternatively, right click on Analysis under the & [ singleTraceTutorial*
design tree in Project Manager. Hover over Add 4 ZsDesion? (ModalNetwork)”
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3. You can solve for either a single frequency or multiple frequencies. Ansys will sweep
through a range of frequencies either way, and use this to generate data for S-
parameter plots. At this stage, you are selecting frequencies at which you will be
able to plot the H-field on the model itself.

a. Multiple frequencies can be useful when trying to diagnose problems in the
model.

4. In the Driven Solution Setup window, you can adjust the frequencies you solve for,
maximum delta S, and maximum number of passes.
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Delta S characterizes the mesh sensitivity for the S-matrix, which controls the
convergence of the adaptive solution. A smaller delta S results in a more
accurate solution.

For most cases, a delta S of 0.02 is best.

The maximum number of passes is the maximum amount of times HFSS will
refine the mesh as it attempts to converge. If the allowed amount of adaptive
passes is low, the solution will not fully converge, and HFSS will return a
warning.

20 passes is generally sufficient. You may go lower if the solution is taking
especially long. If your solution does not fully converge, increase the number
of allowed passes and re-run the simulation.

Driven Solution Setup X

General IOmions ] Advanced ] Expression Cache ] Derivatives I Defaults ]

Setup Name Setup1
W Enabled [~ Solve Ports Only
Adaptive Solutions
Solution Frequency: " Single % MultiFrequendes " Broadband
Frequency Unit Max. Delta 5 Add
Remove
Maximum Number of Passes 20|
Use Defaults
HPC and Analysis Options...

5. The Edit Frequency Sweep window should appear once you confirm your solution

setup.
a.

[f this window does not pop up on its own, right-click on your solution setup
(which should have appeared under Analysis) and select Add Frequency
Sweep.

Set the sweep type to “Interpolating”.
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f.

Set your sweep start and end to reasonable values. Make sure the frequencies
you chose in your solution setup fall within this range.
~400 points for 10 GHz typically works well for smooth plotting.
Check the box for Save Fields (At Basis Freqs)
i. This is what allows you to plot the magnetic field onto your model!
This is very useful for assessing whether the simulation has run
correctly.
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Sweep Type: |Irﬂerp0lating ﬂ
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Add Above Add Below Preview ... |
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e
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You will be able to find your Setup and Sweep & [ SingleTraceTutorial*
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Running the Simulation:

1. Under the Simulation tab in the top banner, click Validate. This runs a validation
check. Make sure there are no errors or warnings.

o] S, B

Mesh Mesh  Setup Sweep  Optimetrics \ Validate Analyze

Settings Feedback - All
Model Simulation Results Automation Ansys |
Validation Check: SingleTraceTutorial - HFS5Design2 X
¥ Design Setlings
Qy HF53Designz ¥ Cable Setup
" 3D Model
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¥ Mesh Operations
¥ Analysis Setup
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@ Radiation

| Cloze |

2. Under the Simulation tab, click Analyze All.
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[
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3. Wait for the simulation to finish running!
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Viewing Solutions:

1. Atthis point, it is best to make sure all model objects are transparent.
2. Plotting magnetic field
a. Select any geometry on your model. Right click, hover over Plot Fields, hover
over H, and select ComplexMag_H.

Next Behind
Selection Mode
Select Objects
Extend Selection

Go to History
Measure
View
Edit

Group
Create 3D Compenent...
Replace with 3D Component.

Assign Material...

Create Amay .. 3 > |
Create Open Region ... H > Mag_H
Update Open Region Padding.. . > ComplexMag_H
= Q > Vector_H
: Assign Boundary > cther R
Assign Excitation >
B ey )
Assign Mesh Operation > Radiation Field... e
Assign Mesh Region... Named Expression..
shange. (11:18:45 AW Oct 18,2024 Plot Fields > Marker >

ent change. (11:48:21 AM Oct 18, 7
using HFSS - Solving Disinbuted. (2; ~ Plot Mesh..
Oct 25, 2024) Plot VRT >
)PM Oct 25, 2024)
Plot Particles..

b. The Create Field Plot window will pop up. You can plot the magnetic field at
any of your basis frequencies and choose which model object to plot on.

Create Field Plot X

™ Specify Hame IComplexMag_H1 Fields Calculatar ... | Surface Smoothing ...
I~ Specify Folder [ Fiald - Category: Im
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Freq [ Wechor_Jsurf
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ABS_Q

I~ Plot on suiface only

Smoath)
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Done I Cancel |
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c. You should be able to view the magnetic field overlay on your model.

H Field [A/m]

29588210
l 27615774
25643335

23570896
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1775.3582
1578.1144
- 1380.8706 1

11836267
986.3829
789.1391

591.6953

3946515

197.4077
0.1638

d. You will find plotted fields under Field Overlays under the design tree in
project manager. Right click on a plot to modify or delete it.
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3. Plotting S-parameters.

a. Right click on Results under the design tree in project manager. Hover over

Create Modal Solution Data report, and select Rectangular Plot.
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Save
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Create Document
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Browse Solutions...
Clean Up Solutions...
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Apply Solved Variation...
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=) Zoom Out
Rectangular Plot
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Polar Plot

Data Table

Smith Chart

3D Rectangular Plot
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b. You will be prompted to choose a variable and units. Choose these

appropriately and click New Report.

K Report: SingleTraceTutorial - HFSSDexign2 - New Report - New Trace(s)
e Trace 1 Families I Families Display I
Solution:  [Semwp1 : 5w S
Pl Swesn Primary Sweep: ‘Freq j |AH J
Domain: e -
Sieep X: ¥ Default [ Freq =
R
i [d91S 2, 1) Fjrr:?;on‘..
Category: Quannty:\ ﬂ Function:
Variables <none: ~
Qutput Variables ang_deg
ang_deg_val
Y Parameter ang_rad
arg
cang_deg
cang_deg_val
cang_rad
dB 10normalize
dB 20normalize
Active 5 Parameter dBc
Active Y Parameter dBm
Active Z Parameter dBu
Active VSWR im
Update Repart Passivity mag
Design normalize v

W Real time

Qutput Variables... | Opﬁons‘..|

Mew Repart | ‘

c. The appropriate plot will be generated.
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Miscellaneous

1.

To delete an object: Right click on the object name, hover over Edit, then select
Delete.

Create global variables for all important properties!

a. Type “$” followed by your variable name into any size or position box in the
properties window and click the enter key. Ansys will recognize any non-
numerical value as a variable, and prompt you to define it.

i. $ ensure the variable is saved as a “Project Variable” and can be
accessed from Project Manager (right click on the file name, and click
Select Project Variables).

To easily orient to a specific view of your model:
a. Right click on your model, hover over View, and select Apply Orientation.
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